Jump to content
  • 0

Firmware Upgrade on Retevis RA89 didn't take.



I downloaded everything. Followed the instructions to a "T" and keep getting "Communication Timed Out" message and check the baud rate. I know everything is set up right, I have WINE set to Win10 and even tried Win11, I've installed drivers and still, NOTHING. So, what's the deal??? I guess another Bricked Radio is going back to Amazon?


On a side note. All the "cheap" radios I've bought(UV-5R, UV-82 and A36 Plus) have worked fine. So why can't manufactures make a $50+ dollar radio work as well as the sub-$30 dollar radios do??


Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
3 hours ago, WRYC373 said:

Did you back up the firmware first? I know chirp on linux can be odd so id always back up firmware before trying to modify it. If you actually fully bricked it yeah return it to amazon.


You can't back up the firmware in CHIRP. I think you're talking about the codeplug(frequencies and settings) which have nothing to do with a firmware update. There's an entirely different program that you use to update the firmware. I'll post a link to YouTube. 



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Guidelines.