Jump to content


Photo

Odd TK-840 programming issue

Kenwood TK-840 programming KPG-25D

Best Answer WQXR317 , 16 July 2019 - 01:07 PM

Ah ha!!! Problem solved!

 

I had thought, incorrectly, that TA, aka Talk About, is Kenwood's way of saying "no PL", or QT/DQT.

 

I just checked my programming. I fat fingered the transmit frequency on one of the entries. TA is just Kenwood speak for "simplex". 

 

I feel a little dumb and humbled, but you learn something every day, right?

 

Thanks guys for jumping in to help!

Chris

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 WQXR317

WQXR317

    Newbie

  • Members
  • Pip
  • 2 posts
  • LocationMaple Valley, WA
  • GMRS Callsign:WQXR317
  • Ham Callsign:KA0ZRW

Posted 15 July 2019 - 09:45 PM

Hello all,

 

(I posted this to Radio Reference too, today. I'll also cross-post the solution for folks.)

This has to be a common problem, as all four of my 840s exhibit this issue.

I have a set of frequencies ("groups) set up in KPG-25D in two "systems". Software is working great in DosBox. (Need to donate to those guys!) See the attachments.

Problem comes in after I push this config to the radios. The issue isn't in the KPG-25D software, that I can tell, since the config is fine, and it writes to the radios without any issues. The problem shows up when I'm flipping through the "groups" in the TK-840 itself. Once I get up to #12, the TA icon shows up. Everything above entry 11 turns into "Talk about" and doesn't keep the QT/DQT settings. System 2 groups (aka, the second set of frequencies programmed into the interface) don't have any QT/DQT config in the radio...they're all TA.

I looked in all the options and nothing seems obvious, like a "ignore QT/DQT decode and encode after entry 11", but maybe there's something else that is a little less obvious?

I've also tried reducing the number of entries and changing the radio model to Sp, just to see. No differences in the radio behavior.

Any help would be greatly appreciated.

Chris

Attached Files


--

Not new to hamming, but new to GMRS'ing.

WQXR317/KA0ZRW "Zebras Running Wild"


#2 marcspaz

marcspaz

    Advanced Member

  • Members
  • PipPipPip
  • 269 posts
  • LocationLocation Location

Posted 16 July 2019 - 12:42 AM

EDIT:  Before all that stuff below, try setting the program to just encode, not encode and decode.  The radio may not like the tone squelch combo, even though its a programing option.

--------------------

 

That's odd.  Its been a long time since I have used one.  I may be thinking of another model, but IIRC, TA is something that typically has to be manually selected and it is selected on the per group basis.  If you press and hold the the AUX button (or scan. don't remember), and then power on the unit, that puts the radio in FPP mode.  From there you can scan through the menu options to enable or disable TA on a specific group.

 

If that doesn't help, I would see if you can find someone with a working radio and clone their unit to yours.  From there, make a backup copy on your computer and then try to mod the image again.

 

Also, what version of Windows are you using?  That software was created for DOS and DOS hasn't existed since 1995.  If you have Windows 7 or older, you can make a dual-boot computer with DOS 6.0 or 6.1.  The command prompt on anything newer than Windows 95a is not true DOS, but rather it emulates DOS.  You may be having a timeout issue while programing it due to the emulator timing out.  I have the same issue on one of my radios.  If I upload the configs once, it fails to set everything.  However, if I upload it 2 or 3 times back to back, it works fine. 

 

The reasoning behind it is the radio is taking to long to send the kill command, indicating to the software that the programing is done, so the software times out.  When you do multiple writes, one after the other, the second and third attempts don't have to do anything but verify the settings are already present.  If no change is needed, it keeps going and eventually finishes.  The only caveat is, you have to keep it in the programing mode.  If you reset the radio and then try to flash it again, its the same as starting from scratch, and it won't work.

 

I am a computer systems engineer with over 30 years of experience.  I have been specializing in Microsoft operating systems since 1991.  To this day, I have not figured out how to change the TTL in the CMD DOS emulator... so I just put up with it.

 

I hope this helps.  If it doesn't, I hope someone is able to get you the support you need.  Looking forward to your follow-up.  Good luck!



#3 res510cue

res510cue

    Newbie

  • Members
  • Pip
  • 3 posts
  • GMRS Callsign:WQSY467
  • Ham Callsign:K4XXX

Posted 16 July 2019 - 12:54 AM

Have you tried version 3.02 of the software? Which is the windows version, not the dos version.
  • marcspaz likes this

#4 Jones

Jones

    Advanced Member

  • Members
  • PipPipPip
  • 209 posts
  • GMRS Callsign:WQYM541
  • Ham Callsign:KB0HAW

Posted 16 July 2019 - 10:02 AM

Also, what version of Windows are you using?  That software was created for DOS and DOS hasn't existed since 1995.

 

He said he was running DOSBox.  If you're not familiar with it, see:

https://en.wikipedia.org/wiki/DOSBox

-or-

https://www.dosbox.com/

 

It is VERY good emulator software.  I have not had problems, but that is not to say that this particular bug might not exist.  I don't even try to use the built-in to Windows DOS "Command Prompt" boxes anymore, unless I am trying to command something in Windows.


  • marcspaz likes this

#5 WQXR317

WQXR317

    Newbie

  • Members
  • Pip
  • 2 posts
  • LocationMaple Valley, WA
  • GMRS Callsign:WQXR317
  • Ham Callsign:KA0ZRW

Posted 16 July 2019 - 01:07 PM   Best Answer

Ah ha!!! Problem solved!

 

I had thought, incorrectly, that TA, aka Talk About, is Kenwood's way of saying "no PL", or QT/DQT.

 

I just checked my programming. I fat fingered the transmit frequency on one of the entries. TA is just Kenwood speak for "simplex". 

 

I feel a little dumb and humbled, but you learn something every day, right?

 

Thanks guys for jumping in to help!

Chris


  • Jones and marcspaz like this

--

Not new to hamming, but new to GMRS'ing.

WQXR317/KA0ZRW "Zebras Running Wild"


#6 berkinet

berkinet

    Advanced Member

  • Members
  • PipPipPip
  • 328 posts
  • GMRS Callsign:WQYR510
  • Ham Callsign:WB6TAE

Posted 16 July 2019 - 01:32 PM

TA as in Talk-Around

Everything we hear is an opinion, not a fact. Everything we see is a perspective, not the truth.

-- Marcus Aurelius


#7 marcspaz

marcspaz

    Advanced Member

  • Members
  • PipPipPip
  • 269 posts
  • LocationLocation Location

Posted 16 July 2019 - 03:29 PM

Yea, lots of vendors use it as a quick method of switching to simplex mode.  I think its more of a pain than just switching to to simplex, so I don't use it.







Also tagged with one or more of these keywords: Kenwood, TK-840, programming, KPG-25D

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users