Jump to content
  • 0

Running Node on Raspberry Pi 4/Modifying Hamvoip


FrostyFruits
 Share

Question

Before doing anything. DO NOT USE the sd card your node is currently running on. Get yourself a blank sd card incase there's any issues, you can just pop your original sd card back in.

 

Files to download:

pi4.zip nodeupdate.zip template.zip

 

DON'T FORGET TO PORT FORWARD to the local ip address and port number used.

 

First use winSCP to log into your current node that's running. Open up iax.conf to get your node password.

/etc/asterisk/iax.conf

image.png.027ee825cbc8bdacba2b45db5e22c2fe.png

 

Head over to hamvoip.org to download the newest image file.

image.thumb.png.3a0e1b5a1eb1b2635690aa08468cbea0.png

 

Make sure you have Win32 Disk Imager installed. Use it to install the new image to the blank sd card. 

image.png.6daa9a1a9323536c9c37741ed7540c45.png

 

After it's done installing don't remove the sd card yet. Open it up in file explorer and add the 2 files in pi4.zip to it. 

image.thumb.jpeg.b282941b4952c2b29aa48da70dfdb8d4.jpeg

 

You can now safely remove sd card and add to your Raspberry Pi 4. Let it boot up with ethernet cable installed for a few mins. Log into your router and look for the newest ip address/name. Mine was labeled as alarmpi 192.168.1.192.

Use the ip address and SSH into it with winSCP using the default credentials. There's a few things your gonna wanna change.

 

Download nodeupdate.zip and copy/paste the files to the correct folders.

/usr/local/etc/rc.updatenodelist

image.png.5b6a1d83bf79c71abe50dfaa9a4827e0.png

 

/var/lib/asterisk/rpt_extnodes_gmrs

image.png.ce882ab1daf1ea99dda0a5b701ab2fb9.png

 

Next download template.zip and install those files in the correct folder.

/usr/local/etc/asterisk_tpl/

image.png.ef064c6abc09e8c4ec1de22ca70b0699.png

 

 

You can now log in with putty and go through the node set up process. Change your hostname to node-XXXXX or whatever you'd like. Add your node number and password when prompted. 

After your done with the node setup you can use the menu to change your wifi. Let your node reboot.

Use winSCP to log back into your node and navigate to extensions.conf to add your node number where it says NODE = ${NODE}. It doesn't change during the setup process. 

 

/etc/asterisk/extensions.conf

image.png.e084b5f8c3f5ff015687a6f86823036b.png

 

Go into rpt.conf and look for extnodefile and change it to the following if it isn't already set.

image.thumb.png.127ed7a7a26076e0484ef73b0cadbd5b.png

 

While in winSCP hit the putty icon

image.png.589c5da4cb06ee70a135f6729b91f78d.png

 

When the menu pops up hit 9 to enter command line.

Change your crontab -e to run rc.updatenodelist

image.thumb.png.b4c38d7540dec466498dea5f3adb5212.png

You should be able to connect to other nodes at this point.

Don't forget to check out the updated tone list I added in rpt.conf

image.thumb.png.98b365bb75cfb9faf5ef271ebf8c505c.png

 

 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Setting up Supermon

 

Log into your node with putty and change directory.

cd /var/www/html/supermon

 

Once your in that directory your gonna wanna change the admin password

htpasswd -cB .htpasswd admin

 

Now go to Supermon on your ip address

yournodeip/supermon

 

Click login on the left and login with admin and your password.

Next we're gonna wanna change some settings. Click Configuration Editor

 

Go to allmon.ini and hit edit file. Change it to the following info with your node# to your node, set passwd= as your password you just set up.

[node#]
host=127.0.0.1:5038
user=admin
passwd=secret
menu=yes
hideNodeURL=no


[All Nodes]
nodes=node#
menu=yes

[lsNodes]
url="/cgi-bin/lsnodes_web?node=node#"
menu=yes

[myGMRS.com]
url="http://network.mygmrs.com"
menu=yes

 

Don't forget to hit WRITE edits at the bottom when done.

Next go to global.inc and change all the info to your info. Callsign, Name, Location, Zip

 

Now go into common.inc and find the section about Allstar Allmon Database, change to the following info

// AllStar allmon database
//$ASTDB_TXT = "/var/log/asterisk/astdb.txt";
$ASTDB_TXT = "/var/lib/asterisk/rpt_extnodes_gmrs";
//
// AllStar rpt_extnodes file --- not present in DNS mode.
$EXTNODES = "/var/lib/asterisk/rpt_extnodes_gmrs";
//
// AllStar Echolink database dump
$ECHO_DB = "/tmp/echolink.db.gz";
//
// Private AllStar nodelist
$PRIVATENODES = "/var/lib/asterisk/rpt_extnodes_gmrs";
 

WRITE edits when done.

 

You should now see your node and all your stats.

If you wanna control your node from an external ip address make sure you port forward port 80 to your node's internal ip. 

Make sure you keep up with your public ip address if you don't have a static ip. Otherwise you won't be able to connect. 

Link to comment
Share on other sites

  • 0

I noticed when people were transmitting I would lose part of the transmission every few seconds, sometimes the whole transmission then I would hear my courtesy tone. I noticed this when I had my phone linked in with DVSwitch while monitoring my radio. I did some playing around in the simpleusb.conf setting and found that if I changed it from log to linear my audio would be fine without issues.

To change the settings log in with putty, on the main menu hit 12 for simpleusb tune menu

image.png.baf7ca307a6705bdae45a3bb1eb69762.png

 

After your in the simpleusb menu hit 5 then number 2

image.png.60a58152fcdd03c6a4dbf4765d65fdcb.png

When your done making changes hit W then 0. Make sure to restart asterisk when done making changes by selecting option 13 from main menu. 

Link to comment
Share on other sites

  • 0

Thanks for the writeup. We've found it very valuable. I'd like to add that in the steps to use WinSCP to copy/place the files rc.updatenodelist and rpt_extnodes_gmrs you might not have mentioned to the users to use F9 and make them executable. Otherwise they won't do anything. When logging onto your node via SSH the default HamVOIP port is 222 and the login is root/root. Also the advice "If you wanna control your node from an external ip address make sure you port forward port 80 to your node's internal ip." won't work for in the majority of cases port 80 is blocked or leads to the router page. Either do a translation like 80 external->50000 internal or add a Listen line in /etc/httpd/conf/httpd.conf to make the web server respond on 50000. Also /etc/asterisk/manager.conf needs 

[general]                                                                       
displaysystemname = yes                                                         
enabled = yes                                                                   
webenabled = yes                                                               
port = 5038                                                                     
and
;bindaddr = 127.0.0.1   ; Local interface only!                                                           
bindaddr = 0.0.0.0    ; Not secure

 

I just didn't want people to get stuck. Thanks again

 

-Pres WRJL719/W2PW 

Link to comment
Share on other sites

  • 0

A couple of other things. At the step that says "Change your crontab -e to run rc.updatenodelist", because the screenshot runs off the left edge, you can't see that there is an asterisk (shift-8) (never use the numeric keypad) at the beginning of the line. So

/5 * * * * /usr/local/etc/rc.updatenodeist should be
*/5 * * * * /usr/local/etc/rc.updatenodeist

as does the line above it for AutoSky

PS: you can make your PuTTY window look a LOT cleaner by doing the following:
In Putty, 
Window...Appearance...Font... change to 18point
Translation... Remote character set make it CP437
Session...Default settings...Save

Also update any saved sessions you may have. Actually, I don't save sessions. What I do is in WinSCP I choose
Options...Preferences...Integration...Applications... and tick all 3 (versus the default middle one) and then WinSCP invokes PuTTY.

One other WinSCP tip: if you can't "see" a file that is there (example: /srv/http/supermon/.htpasswd) then click lower right to show hidden files. 

You can edit files in Supermon Configuration Editor, but if it warns you about the file being read-only, go into WinSCP, go to the file such as /etc/asterisk/rpt.conf and hit F9 to change the properties of the file from 0644 to 0666

That's about it for now. 73

-Pres WRJL719/W2PW

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Guidelines.